grails, maven, ivy und Probleme beim Auflösen der Dependencies

Eben hatte ich ziemliche Probleme weil meine Grails build nicht mehr liefen und mit der folgenden Felermeldung abgebrochen sind:

——System.out:———-
| Loading Grails 2.1.1
| Error WARNING: Dependencies cannot be resolved for plugin [vaadin] due to error: ivy pattern must be absolute: ~/.m2/repository//[organisation]/[module]/[revision]/[module]-[revision](-[classifier]).pom (Use –stacktrace to see the full trace)
| Error WARNING: Dependencies cannot be resolved for plugin [database-migration] due to error: ivy pattern must be absolute: ~/.m2/repository//[organisation]/[module]/[revision]/[module]-[revision](-[classifier]).pom (Use –stacktrace to see the full trace)
| Configuring classpath.

Lösung was die Angabe eine vollständigen Pfads für das Maven local repository:

Nicht gut:

<localRepository>~/.m2/repository/</localRepository>

so geht´s:

<localRepository>/path/to/local/repo</localRepository>

(nicht das es eine Zeile darüber im Kommentar steht…)

 

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.